Intelligence Hub

Blank or incorrect uPerformSystem password causes "Document Not Found" in Publishing Queue

Symptoms

  • A document has the status of "Document Not Found" in the publishing queue.
  • Similar text will appear in CollabConsole.txt indicating a login failure for uPerformSystem: 

[Aug 27, 2012 11:50:25 AM (TP-Processor1_2)]: Login failed for uPerformSystem

  • The following error occurs in ServerErrors.XML:

  <Message>The remote server returned an error: (401) Unauthorized.</Message>

  <StackTrace>at System.Net.HttpWebRequest.GetResponse() at ANCILE.uPerform Vignette.BusinessObjects.WebClientWrapper.DownloadDataNoRedirect(Uri address) atANCILE.uPerform.CMS..GetBytesFromServer(Uri uriCredentialSet CredentialsToUse, Dictionary`2 postData) at ANCILE.uPerform.CMS.Vignette.GetBytesFromServer(Uri uri,CredentialSet CredentialsToUse, String postData) at ANCILE.uPerform.CMS.Vignette.GetStringFromServer(String uriCredentialSet CredentialsToUse, String postData) atANCILE.uPerform.CMS.Vignette.GetDocumentStatus(String DocumentGUID, String& AdditionalInformationCredentialSet CredentialsToUse)</StackTrace>

  • The following SystemPassword line in the ANCILE.uPerform.ServerConfiguration.DLL.config either does not exist, or contains no value:

<add key="SystemPassword" value=""/>

Environment

  • Product: ANCILE uPerform
  • Version: 4.50 or later

Cause

As part of the enhanced security measures implemented in 4.50, the uPerformSystem account password is randomly generated during the server configuration section of the uPerform Server installation process.  As a result of this security measure, when reinstalling or migrating application servers, the password needs to be manually reset. If the password is not reset, there will be a password mismatch that will result in a Document Not Found status in the publishing queue.                        

Resolution

Reset the password of the uPerformSystem account, per the Reset the uPerformSystem account password in uPerform Server 4.50 and later KB article.

If you are experiencing this issue, ANCILE support also recommends resetting the password of the SolutionManager account, per the Resetting the SolutionManager Account Password in 4.50 or Above KB article.

Additional Information

If these steps do not resolve your issue, please review "Document Not Found" Status in Publishing Queue in ANCILE uPerform

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments