Intelligence Hub

Audio Files do not Play in Published Content when the uPerform Application Server is Running on Windows Server 2008 or 2008 R2

Symptom

Audio does not playback in published content when uPerform Server is installed on Windows Server 2008 or 2008 R2.

 

Explanation

In order for .mp3 files that were encoded from a .wav file to play properly, the application server must have the necessary codecs installed.  If Windows Media Player is not installed on the server, the codecs will be not be installed.


Affects Version(s)

4.30 and above

Resolution

On the application server, install Windows Media Player via the Desktop Experience feature to ensure the required codecs are installed and republish the affected content.  To install Windows Media Player on Windows Server 2008, perform the following:

NOTE: Installing Windows Media Player using the instructions below requires a restart of the server.

  1. Open Server Manager.

  2. Click Features in the left hand pane. 

  3. Click Add Features in the Features Summary section.

  4. Select the Desktop Experience checkbox.  When prompted, "Add Features required for Desktop Experience?", click the Add Required Features button.

  5. Click the Next button.

  6. When prompted, "Do you want to restart now?", click Yes to restart the server.  If you do not want to restart at this time, click No.  You can restart the server at a time that is convenient but audio playback will not work.

Once the Desktop Experience feature has been installed and the server has been rebooted, republish any of the affected published content and test to ensure the audio is playing as expected.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments