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Error: "The request failed due to an internal server error" when updating definitions in uPerform Client

Symptoms

  • Error: 'The request has failed due to an internal server error. An error occurred on the Server and the document term definitions were not able to be updated.'
  • Unable to update glossary definitions in uPerform Client
  • When trying to update definitions for an existing term on the uPerform server, the fields do not appear correctly and admin is unable to update.
  • Monitoring Service will not restart
  • Error when restarting the Monitoring Service: 'The evaluation period has expired.'

Environment

  • Product: ANCILE uPerform

Cause

ServerConfiguration.DLL file was blank due to low disk space on the uPerform server. 

Resolution

  • Restore a backup of the ServerConfiguration.DLL file and restart the monitoring service 

OR

  • Manually recreate the .DLL file (requires passwords and host name, not recommended)
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