Intelligence Hub

Glossary import fails when it reaches any terms with & (ampersand) symbol

Symptoms

  • The import process fails when it reaches any terms with & (ampersand) symbol
  • All terms before the failure are imported successfully, but any terms that come after the problematic one are not imported

Environment

  • Product: ANCILE uPerform
  • Version: 5.20.x

Cause
Terms containing & (ampersand) symbols

Resolution
This issue is resolved in uPerform 5.30. Please download and install the latest update to resolve the issue.

Workaround
If you are unable to install the latest version at this time, we recommend using one or more of the following steps:

  1. Delete the terms with & (ampersands) from the provided master copy of the glossary then manually add the terms into the glossary on the uPerform Server
  2. Rename the & (ampersand) in the affected terms to "and" which will allow the glossary to be imported
  3. Remove the  & (ampersand) and replace it with another letter

Defect Number
D-10496
 
Additional Information

  • There is no issue if ampersand is in the definition
  • There is also no issue when adding term with ampersand manually into the glossary
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments