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Unable to publish uPerform documents and courses to all formats on the uPerform Server

Symptoms

- When in the publishing queue of the uPerform server, documents and courses status are listed as failure
- Document or course publishes successfully when published in the uPerform client

Environment

  • Product: ANCILE uPerform Server

Cause

One of your configuration files contains a value that is below the default setting. This lower value could result in a memory error during the publishing process.

Resolution

  1. On the uPerform Application server, navigate to Control Panel > Administrative tools > Services
  2. Stop the Vignette Collaboration service. (NOTE: the uPerform website will be unavailable until the service is restarted)
  3. Open [Install Directory]\Collaboration\collab.props in Notepad.
    Important Note: Always make a backup copy of any file in the Collaboration folder before making changes. Modifying these file incorrectly can have serious consequences to your system. If you are uncomfortable making these modifications please submit a ticket for assistance from ANCILE Customer Success.
  4. Change the service.maxheap value to '1400'. (Line # 14)
  5. Start the Vignette Collaboration service .
  6. Once the website is available, attempt to publish the document\course that previously failed.

Additional Information

  • Error in the CollabConsole.txt file: [Apr 9, 2015 12:07:40 PM (TP-Processor7_29)]: WARNING: root cause throwable is null.
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