Intelligence Hub Browser Support Changes Coming June 24, 2018

Beginning June 24, 2018, moderns browsers such as Internet Explorer 11, Mozilla Firefox 27, Google Chrome 30, or Apple Safari 7 or newer will be required to access the Intelligence Hub and the uPerform manuals.  

To ensure the security of their systems, and maintain compliance with the PCI Data Security Standard (PCI DSS) for safeguarding payment data, Zendesk (ANCILE's support site vendor) is updating its product suite to require a minimum of version 1.2 of TLS for all HTTPS connections.

If you have any questions, please submit a ticket to ANCILE.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments